WYSIWYG Editing - TinyMCE [Part 1]

15 replies [Last post]
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008

Last night I got Tinymce and I installed the Wysiwyg module.

http://drupal.org/project/wysiwyg

I set up a profile and the editor seemed to be working, but now all the line breaks are stripped.  I had spent half an hour on my first blog post here and then somehow ended up losing it because I just could not get it to post with the line breaks.

Several hours later, as I'm posting problem after problem, I installed module TinyMCE. So after I lost my line breaks, I installed the Tinymce module:

http://drupal.org/project/tinymce

But then couldn't create a profile:

warning: Invalid argument supplied for foreach() in /home/trado/public_html/includes/form.inc on line 1194.

I don't know what to do anymore. 

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
First functioning

"First functioning version of TinyMCE for Drupal 6. Still has issues. Not recommended for a production site." I first posted the above with the editer DISABLED and I had the line breaks. Then I went to edit and the lines disappeared even though I saw no editor button.

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Just tried it again, went to

Just tried it again, went to edit, disabled the editor and then all the line breaks disappeared.

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Thought I'd try the Tinymce
Thought I'd try the Tinymce module one more time, with WYSIWYG module disabled, but got the same error when trying to create a profile: warning: Invalid argument supplied for foreach() in /home/trado/public_html/includes/form.inc on line 1194.
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Back to wysiwyg.test.

Back to wysiwyg.

test.

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
I don't get it.I can even SEE

I don't get it.

I can even SEE the HTML, the </p>.  So why isn't it THERE?

I checked the wysiwyg setup again.  There is THIS option under CLEANUP and OUTPUT:

The ONLY option checked:

Verify HTML

If enabled, potentially malicious code like <HEAD> tags will be removed from HTML contents.
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Just for kicks, I checked

Just for kicks, I checked "Remove linebreaks"

If enabled, the editor will remove most linebreaks from contents. Disabling this option could avoid conflicts with other input filters.
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
I'm getting more and more
I'm getting more and more confused. I disabled the Tinymce module, but it still shows up to configure. Tried to uninstall it, but get: "No modules are available to uninstall." HUH? I want to get RID of stuff I don't use. It's impossible to find what I'm looking for as it is. Now what? When I couldn't uninstall Marketplace, I scrapped the entire system and reinstalled Drupal. Obviously, I can't keep on reinstalling and losing EVERYTHING just to get rid of modules I don't use. I suppose I can delete the Tinymce module files, but that didn't work with marketplace. I now have line breaks because I'm using NO editor. Been doing a lot of reading at drupal but haven't found anyone else with this problem.
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Can't get rid of tinymce module
Yup, it's still there. NOT in the module list, but under Site configuration / Adjust basic site configuration options: Fatal error: Call to undefined function _tinymce_plugins() in /home/trado/public_html/modules/tinymce/tinymce.module on line 411
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Created a new wysiwyg

Created a new wysiwyg profile

test

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Hmm, looks like I got a line

Hmm, looks like I got a line break now.

test

test

 

test

 

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
The default settings have the

The default settings have the following checked in Cleanup and output

Verify HTML

If enabled, potentially malicious code like <HEAD> tags will be removed from HTML contents.

Convert <font> tags to styles

If enabled, HTML tags declaring the font size, font family, font color and font background color will be replaced by inline CSS styles.

Remove linebreaks

If enabled, the editor will remove most linebreaks from contents. Disabling this option could avoid conflicts with other input filters.
How weird, didn't think that conversion of the font tags has anything to do with line breaks.
So now I have to hit enter TWICE to actually get a real <p>
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
That looked a LOT better when
That looked a LOT better when I copied/pasted Strange
christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Now I took out the "remove

Now I took out the "remove line break"

Wonder what that does.

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Made no difference.   But I'm

Made no difference.

 

But I'm running out of space, what's happening to my replies?

christine
User offline. Last seen 1 week 6 days ago. Offline
Joined: 11/26/2008
Changed the TinyMCE buttons

Changed the TinyMCE buttons and now I'm losing the line  breaks again.

 

This is so frustrating.

In the preview window I can SEE the CODE!!!! Why is it removed again?